Seite 2 von 3 ErsteErste 123 LetzteLetzte
Zeige Ergebnis 11 bis 20 von 29

YARD / Eventghost + weitere Fragen

Erstellt von enzym, 21.04.2009, 12:39 Uhr · 28 Antworten · 4.425 Aufrufe

  1. #11
    Benutzerbild von AndreWeber

    Registriert seit
    02.08.2005
    Beiträge
    1.446
    Hallo,

    mmh - die Leuchte Signalisiert eigentlich nur - das das RTS/CTS Handshake da ist - dass kann auch durch eine andere Ursache gesetzt sein - z.B. andere Treiber/ Hardware etc. - so unbedingt von YARD muss das nicht sein.

    Naja die USB2seriell Adapter sind meist recht unproblematisch - allerdings würde es mich wundern wenn die als COM1 im System erscheinen - oft erscheinen die auch als COM5 etc.. außerdem gibt es schon einige Nutzer von YARD die genau solche Adapter verwenden - und diese haben so weit mir bekannt ist keine Probleme.

    Daher würde ich erstmal sage - es liegt irgendwo nicht direkt an Y.A.R.D. -- das scheinbar nur schreiben funktioniert - verwundert mich - schon ein wenig - da seit der Firmware 4 alle Befehel bestätigt werden müssen, d.h. wenn das setzen derZeit nicht durch ein Paket quittiert wird - kommt ne Fehlermeldung.

    Es sei denn der Adapter oder deine Verkabelung zum YARD hin / weg hat nen Fehler - so das die Leitung für das schicken von Daten YARD --> PC nicht klappt.


    André

  2.  
    Anzeige
  3. #12
    Benutzerbild von enzym

    Registriert seit
    02.06.2003
    Beiträge
    156
    Hallo,

    YARD läuft wieder - leider nur manchmal und nicht stabil.

    Vorab zur Hardware: Ich habe eine alternative Art der Stromversorgung geschaffen und ein zweites serielles Kabel erstellt, um diese als Fehler auszuschließen.
    Allerdings haben beide Maßnahmen die Funktionsweise nicht verbessert.

    Sicherheitshalber hier meine COM-Einstellungen, nicht dass hier der Fehler liegt:

    (Yard.exe ist auch auf COM4/56000Bit eingestellt.)


    Momentan kommt nach zwei von drei Bootvorgängen (weder YARD noch die Kabel werden irgendwie bewegt o.ä.) der bereits im vorletzten Posting bebilderte Fehler ("Bitte Verbindungseinstellungen überprüfen"). Nach ca. jeden dritten Bootvorgang funktioniert YARD dann, zumindest vorerst.

    Ich starte dann über Eventghost Mediaportal und nach 1-2 Minuten erscheint dann folgende Fehlermeldung:


    Ab diesem Zeitpunkt funktioniert YARD nicht mehr, nimmt also keine Befehle mehr entgegen und meldet unter Yard.exe "Time-Out-Fehler" (Y.A.R.D. function call (...) timed out!).

    Ich bin irgendwie ratlos ...

    Grüße
    Christian

    PS: Wo speichert Yard.exe seine Configurationseinstellungen?

  4. #13
    Benutzerbild von AndreWeber

    Registriert seit
    02.08.2005
    Beiträge
    1.446
    Hallo,

    mmh - du machst mich langsam ein wenig Ratlos - ich vermute das nicht die Y.A.R.D. Platine abschmiert, sondern beim Schreiben von KeyLCD etwas daneben läuft und somit der I2C Bus hängt - erste vorsichtiger Versuch wäre - mal die LCD Steuersoftware deaktivieren - und schauen ob dann alles soweit klappt.
    -- Tut es dann wieder über einen längeren Zeitraum -- kann man ja die LCD Steuersoftware wieder starten -- dann müssten wir uns mal der KeyLCD Konfiguration widmen, kannst du mir mal ein paar Screenshots geben, wie du dein LCD in kLcdConfig.exe eingerichtet hast (die Grundkonfiguration dürfte für mich interessant sein.)

    Die Einstellungen der USB-Seriellen Schnittstelle, dürften für meine Anwendung eigentlich keine Rolle spielen, da ich die Parameter nach dem öffnen der Schnittstelle sowieso nochmal so setze wie ich sie brauche - wüsste also jetzt nicht ob die Einstellungen welche der Dialog dort zulässt überhaupt für mich von Bedeutung wären?

    Die Einstellungen von der Yards.exe findest du in der Registry

    hkey_current_user\Software\Webers\Y.A.R.D\

    (einige der Einstellungen werden aber im EEProm des Controllers selbst gespeichert.)


    André

  5. #14
    Benutzerbild von enzym

    Registriert seit
    02.06.2003
    Beiträge
    156

    Fehler ist immerhin eingegrenzt

    Hallo Andre,

    ich habe jetzt - als ultima ratio - am heutigen Sonntag mein System komplett neu aufgesetzt ... und es hat nichts geholfen, erstmnal ...

    Nachdem ich jetzt auschliessen konnte, daß es am System eigentlich nicht liegen kann, hat mir dann Dein Hinweis geholfen
    ... ich vermute das nicht die Y.A.R.D. Platine abschmiert, sondern beim Schreiben von KeyLCD etwas daneben läuft und somit der I2C Bus hängt...
    Ich habe Y.A.R.D ohne LCDKey Platine getestet, et voila ... alles funktioniert bestens.

    Also scheint es daran zu liegen, daß die LCDKey Platine den i2c Bus "negativ beinflußt". Wahrscheinlich habe ich einen Fehler beim Aufbau gemacht. Ich habe mal die Vorder- und Rückseite eingescannt, vielleicht kann man hier schon einen Fehler erkennen.


    (Zur Ergänzung: Ich nutze ein Noritake VFD)



    Ich würde mich sehr freuen, wenn Du Dir die Mühe machst und hier drüberschaust.

    Grüße
    Christian

  6. #15
    Benutzerbild von AndreWeber

    Registriert seit
    02.08.2005
    Beiträge
    1.446
    ok - die Bestückung und Lötarbeit sieht gut aus - zumindest seh ich jetzt nix wo ich mir gedanken machen würde.

    Aber da du ein VFD angeschlossen hast - von Noritake - mache ich mir Gedanken ob die Bestückung der Kontrastschaltung (rechter Drehregler) so gut ist - wie sieht eigentlich dein Kabel von KeyLCD zum VFD aus? welche Belegung? -- Foto?

    Wie hast du dein LCD im kLcdConfig.exe eingerichtet? Screenshots? würden mich da interessieren.

    Der Pin3 welcher bei normalen LCD's für die Kontraststeuerung verwendet wird, hat
    bei Noritake - da es keinen Kontastregler hat - vielleicht ne andere Bedeutung? (muss ich heut Abend mal nachlesen.)


    André

  7. #16
    Benutzerbild von enzym

    Registriert seit
    02.06.2003
    Beiträge
    156
    Supi, das ging ja fix ...

    Vielleicht noch als Zusatz, um Dich nicht auf die falsche Fährte zu locken:
    Auf wenn das VFD nicht an die LCDKey-Platine angeschlossen ist (das Kabel hierfür nicht in der LCDKey Platine steckt), meldet YARD den obigen Fehler.


    Ich selbst werde heute Abend (wenn ich Zeit finde) mein Verbindungskabel nochmal durchmessen, um diesen Fehler auschliessen zu können.
    Screenshots vom kLcdConfig.exe mache ich ebenfalls.

    Danke + Gruß
    Christian

  8. #17
    Benutzerbild von AndreWeber

    Registriert seit
    02.08.2005
    Beiträge
    1.446
    naja - das Display abziehen, ist auch keine wirklich gute Idee - die Software wartet auf das Ready Signal vom Display ;-) mit einem Timeout der größer ist als die Geduld der Yards Software - und verursacht somit die Fehlermeldung. Wenn muss du das Display mit kLcdConfig.exe schon komplett deaktivieren.

  9. #18
    Benutzerbild von enzym

    Registriert seit
    02.06.2003
    Beiträge
    156
    Ok, dann probiere ich gleich nochmal mit angeschlossenem Display und poste Screenshots.

    Vorab schonmal mein VFD-Kabel:

    (hier nochmal der Link zu meinem FD)

    Das Verbindungskabel zwischen YARD und LCDKey habe ich durchgemessen und ist OK.

  10. #19
    Benutzerbild von enzym

    Registriert seit
    02.06.2003
    Beiträge
    156
    so, hier jetzt die Einstellungen von kLCDConfig.exe:



    Eigentlich funktionierte jetzt alles einwandfrei, bis auf die drei letzten "Noritake"-Buttons unter "Check-LCD" (haben aber noch nie funktioniert).


    "Noritake Ani":


    "Noritake Bitmap":


    Unter "Noritake Grafik Text" passiert nix.

  11. #20
    Benutzerbild von AndreWeber

    Registriert seit
    02.08.2005
    Beiträge
    1.446
    Hallo,

    also da du die Kontrastschaltung voll bestückt hast - und auch dein Kabel Pin3 durchreicht, und Pin3 evtl. als Reset Eingang des Display fungiert - wie im Datasheet beschrieben - könnte das zu Störungen führen, da bedingt durch die externe Beschaltung wohl weder ein sauberer H noch ein sauberer L-Pegel am Pin3 des Displays anliegt - vielleicht hilft es also wenn du mal an deinem Kabel - z.B. oben an der Stiftleiste die 3. Leitung ablötest - und so den Pin3 des Displays überhaupt nicht extern beschaltest?

    Das Verbindungskabel zwischen YARD und KeyLcd hatte ich auch nicht so direkt im Verdacht - sonst hättest du die Platine glaube ich auch nicht konfiguriert bekommen.


    André

Seite 2 von 3 ErsteErste 123 LetzteLetzte

Ähnliche Themen

  1. Einige Fragen zu YARD
    Von lordfritte im Forum Y.A.R.D. Entwicklerforum
    Antworten: 47
    Letzter Beitrag: 28.02.2009, 19:08
  2. LCD und kleiner TFT über Onboard möglich? Und weitere Fragen...
    Von rockshow85 im Forum Grafikkarten & TV-Karten
    Antworten: 11
    Letzter Beitrag: 17.09.2008, 13:10
  3. Zusammenstellung ok? weitere Fragen...
    Von philippege im Forum Beratungscenter (Hier bitte bei Bedarf Eure Zusammenstellungen posten)
    Antworten: 1
    Letzter Beitrag: 10.04.2008, 11:55
  4. Fragen zum Stromverbrauch (und weitere)
    Von Milhouse im Forum Hardware generell
    Antworten: 16
    Letzter Beitrag: 03.08.2004, 20:41
  5. Matrox G400: Diagonale Streifen beim TV Out + weitere Fragen
    Von Skip im Forum Grafikkarten & TV-Karten
    Antworten: 1
    Letzter Beitrag: 18.03.2004, 17:58