Zeige Ergebnis 1 bis 7 von 7

*.avi beide tonspuren gleichzeitig

Erstellt von AlexWenig, 28.04.2012, 19:11 Uhr · 6 Antworten · 1.329 Aufrufe

  1. #1
    Benutzerbild von AlexWenig

    Registriert seit
    29.01.2012
    Beiträge
    140
    Blog-Einträge
    2

    *.avi beide tonspuren gleichzeitig

    Nabend,

    ich wollte gerade mal wieder Futurama schauen und dachte ich hör nicht richtig.
    Deutscher und Englischer Ton Simultan.
    Ich habe ffdshow und den Matroska Media Splitter drauf als Codec.
    im haali interface ist Deutsch eingestellt und ffdshow gibt mir keine Spur zur auswahl.
    Woran kann das liegen?

    Habe auch noch bissle andere Serien durchgezappt und es sind einige die das problem haben.

    Daten der Futurama Folgen :

    Stream 0
    Typ:Video
    Codec: MPEG-4 Video (XVID)
    Auflösung: 640x480
    Bildwiederholrate: 25
    Decodiertes Format: Planar 4:2:0 YUV
    Stream 1
    Typ: Audio
    Codec: MPEG Audio Layer 1/2/3 (mpga)
    Kanäle: Stereo
    Abtastrate: 48000 Hz
    Bitrate: 128 kb/s
    Stream 2
    Typ: Audio
    Codec: MPEG Audio Layer 1/2/3 (mpga)
    Kanäle: Stereo
    Abtastrate: 48000 Hz
    Bitrate: 131 kb/s
    Eigentlich sollten die Bereiche abgedeckt sein laut Google.
    Aber warum gibt mir ffdshow da keine zweite tonspur an sondern sagt es ist gesammt nur eine vorhanden und spielt
    im MCE dann beide simultan ab?

    Danke euch im Voraus...

    Gruß Alex

  2.  
    Anzeige
  3. #2
    Benutzerbild von alROD

    Registriert seit
    24.05.2009
    Beiträge
    2.811
    Blog-Einträge
    6
    Dieses Problem hatte ich noch nie...

    Das oben sind die Daten von einer der "defekten" Dateien? Ich hoffe es meldet sich jemand mit Ahnung dieser Materie, ich bin in der glücklichen Lage das nahezu alles von alleine funktioniert oder ich (meist durch Zufall) eine schnelle Lösung finde. Das kann ich dann auch wiedergeben. Dein Problem kann ich nicht mal reproduzieren, hab´s grad versucht...

  4. #3
    Benutzerbild von AlexWenig

    Registriert seit
    29.01.2012
    Beiträge
    140
    Blog-Einträge
    2
    Nabend alROD,
    wenn du das Problem "reproduzieren" möchtest, kann ich dir gerne einen teil der Folge ins netz stellen. (Sample der Folge. bis 5min war glaub legal)
    VLC bekommt die tonspuren prima getrennt, nur WMP und MCE nicht

    Gruß Alex

    edit: // wenn ich mit Virtual Dub die Datei im Direct Stream Copy erneut speichere ist die 2te Tonspur weg da angeblich ein fehler vorliegt.
    Wie schön, das ich ja nur über 500 Folgen von Futurama und den Simpsons habe die das problem haben...

  5. #4
    Benutzerbild von alROD

    Registriert seit
    24.05.2009
    Beiträge
    2.811
    Blog-Einträge
    6
    Das können wir tun, allerdings habe ich heute und morgen Nachtdienst und solange nur schon überzogenes Datenvolumen. Aber ich kümmere mich gerne darum! Her mit den Dingern, zum Glück ist das ein Luxusproblem, bei dem es nicht um Minuten geht.

  6. #5
    Benutzerbild von Yard2

    Registriert seit
    02.02.2011
    Beiträge
    232
    Hallo,

    Das Problem ist eigentlich uralt.
    Hatte ich früher in alten Windows 2000 Zeiten ;-)
    Ist der Matroska Media Splitter auch für AVI aktiv ?
    Tray Icon unten rechts während das AVI läuft ?

    Wenn ffdshow keine 2 Spuren aus dem Spiltter Filter gegeben werden, kann er auch keine 2 anzeigen.
    ffdshow ist nur ein Decoder, kein Spiltter.

    Oder du suchst mal nach mmswitch.exe.
    Damit konnte man früher das Problem umgehen.

    VirtualDub kann nicht mit VBR mp3 umgehen.
    Dann fliegt das beim Dub wieder raus.
    Da musst du den VirtaulDubMod nehmen. Der kann das.

    VLC nimmt eigene Libs und benutzt keine DirectShow Filter.
    Deshalb kann er die 2 Spuren auch erkennen und dekodieren.


    Gruß,
    Rainer

  7. #6
    Benutzerbild von AlexWenig

    Registriert seit
    29.01.2012
    Beiträge
    140
    Blog-Einträge
    2
    Nabend Yard,

    danke für die info...
    Habe beide codecs mal fix deinstalliert und den Matroska neu installiert.
    Und es läuft.
    ich danke dir

    Gruß Alex

  8. #7
    Benutzerbild von alROD

    Registriert seit
    24.05.2009
    Beiträge
    2.811
    Blog-Einträge
    6
    Eigentlich wie immer, irgendwas neu installieren oder einfach neu starten...

    Im Jahr 2000 war ich gerade Anfang 20, da hatte ich noch ganz andere Interessen als Computer

Ähnliche Themen

  1. DVB-C DVB-S gleichzeitig
    Von gage im Forum Grafikkarten & TV-Karten
    Antworten: 3
    Letzter Beitrag: 11.02.2010, 23:51
  2. LCD und TFT gleichzeitig nutzen?
    Von Mrmulugulu im Forum Grafikkarten & TV-Karten
    Antworten: 3
    Letzter Beitrag: 31.12.2008, 00:01
  3. DIVX File mit 2 Tonspuren
    Von veGa im Forum MediaPortal
    Antworten: 3
    Letzter Beitrag: 21.04.2008, 01:10
  4. Filter für BVid (xvid mit 2 tonspuren)
    Von Phoenix im Forum Software generell
    Antworten: 2
    Letzter Beitrag: 09.06.2005, 17:34
  5. MediaPortal 0.0.0.11: beide Daumen nach oben!
    Von Skip im Forum Software generell
    Antworten: 24
    Letzter Beitrag: 31.10.2004, 23:35