Zeige Ergebnis 1 bis 9 von 9

analog anders, als digital gewünscht

Erstellt von carlaron, 17.12.2004, 09:29 Uhr · 8 Antworten · 1.048 Aufrufe

  1. #1
    Benutzerbild von carlaron

    Registriert seit
    17.12.2004
    Beiträge
    9

    analog anders, als digital gewünscht

    Hallo,

    ich will den Oboardsound gerne für die mp3 Wiedergabe an einen anderen Verstärker ausgeben, als das SPDIF Signal der eingebauten Karte, dass zum DVD Gucken genutzt wird.

    Geht das parallel? und problemlos?

    wie kann ich (außer im Treiber), der Playersoftware sagen, welches Gerät zu verwenden ist?

    und unter linux?

  2.  
    Anzeige
  3. #2
    Benutzerbild von elektrip

    Registriert seit
    03.09.2004
    Beiträge
    35
    Hi
    Verstehe ich Dich richtig, dass Du für DVD eine PCI-Karte nutzt und dort digital DD/DTS an einen Receiver durchreichst?

    Und jetzt möchtest Du mit dem onboard soundchip analog auf einen Stereoverstärker?

    In diesem Falle würde ich die PCI Karte als Windows default audiointerface installieren (im Multimedia Control Panel), weil der Software DVDP wohlauf dieses interface zugreift. Zumindest für PowerDVD und WinDVD kann m.W. das audiointerface nicht separat konfiguriert werden.

    Im Winamp z.B. kannst Du dann das audiodevice des onboard chips unter den output plug-ins einstellen. "xy WaveDevice analog 1 out" oder ähnlich benannt. Das geht in den meisten seriösen Playern in den audio Einstellungen. Mir ist eigentlich nur der Windows MediaPlayer bekannt der diesbezüglich keine Einstellungen zulässt.

    Auf "parallel und problemlos" würde ich mich ohne Test nicht verlassen. Fängt schon an beim Hardware Setup und den IRQ Einstellungen. Die Soundkarten sollten sich die Ressourcen nicht teilen müssen (IRQ-Sharing!). Auf OS Ebene müssen beide Treiber problemlos aneinander vorbeikommen, je nach Geräte-Kombination eher ein Glücksspiel. Kann aber funktionieren, hatte auch mal so eine konfig.
    Soviel zu "problemlos".

    "Parallel" funktionierts dann, wenn obige Voraussetzungen gegeben sind, alle anderen Probleme behoben wurden und genügend Systemressourcen vorhanden sind für gleichzeitiges DVD und MP3 Playback auf verschiedene Soundkarten. Da fallen 8 Kanäle zusammen, die jeweils decodiert und gewandelt werden müssen. Einfache onboard chips und PCI Audio dürften ihre Last auf der CPU erledigen. Und ohne Hardware Decoder verschlingt auch das MPEG2 Video seinen Anteil zum decodieren Jetzt noch eine Prise Netzwerk oder USB2 Verkehr und ein Flaschenhals (PCI Bus oder chipset, cpu, memory...) macht dicht. Stotter.

    Was eher funktioniert, ist mit 2 baugleichen Karten zu hantieren, wenn der Hersteller das unterstützt. Ganz sicher geht es mit kaskadierbaren Karten wie sie von Terratec Producer, RME oder Creamware angeboten werden. Allerdings sind das andere Preisregionen.

    Mit Linux kann ich Dir leider nicht weiterhelfen. Probiers doch mal aus. Unter Win XP hatte ich 3 komplett unterschiedliche audiokarten im System und alle outs waren benutzbar (parallel nicht getestet). Jede Karte für ihren Zweck. Nun ja zuletzt ging das auch nicht auf und 2 Karten mussten raus, aber hauptsächlich weil die onboard und der Soundblaster ihren jeweiligen Zweck nicht optimal erfüllen konnten...aber das ist andere Baustelle.

    Ich will Dich nicht entmutigen, im Gegenteil, auf einer modernen Platform und zeitgemässem OS stehen die Chancen gut das es gleichzeitig und stressfrei geht, sauber konfiguriert. Hoffe es hilft

    (edit) Auf einer etwas mehrbesseren soundkarte lassen sich sp/dif und analog getrennt und parallel ausgeben. Das gesamte potentielle Hardware Problem entfällt. Meine RME z.B. kann alle I/Os gleichzeitig mit gespiegeltem oder unterschiedlichem Signal bedienen. Somit läuft der DVDP über den Toslink und das .mp3 über den analog out auf Wunsch. Voraussetzung das die Karte wirklich vernünftig designt ist, auch der Treiber, damit die "wavedevices" separat im Treiber und damit in den Applikationen verfügbar sind. Ich denke, das ist heute standard ausser ev. beim onboard audio? (/edit)

    Gruss
    elektrip.

  4. #3
    Benutzerbild von carlaron

    Registriert seit
    17.12.2004
    Beiträge
    9
    Hallo,

    Frohe Weihnacht erstmal...

    Danke für die ausführliche Antwort. Ich werde es wohl einfach mal probieren müssen.
    Wenn es klappt, werde ich mich nochmal melden..... Allerdings wird das aus Zeitgründen wohl eher was im neuen Jahr.

    Bis denn,

    Guten Rutsch

  5. #4
    Benutzerbild von Baschtler

    Registriert seit
    03.12.2004
    Beiträge
    133

    Idee

    @ carlaron: Scheint wohl nicht geklappt zu haben .


    Ich versuche im Moment etwas ähnliches.

    Hier erst mal meine Audio-Konfiguration:

    1. Primäre Soundkarte: Creative Soundblaster Platinum 5.1 (Mit LiveDrive)

    • eingestellt auf analog Audio (Quadrophonie 4 Lautsprecher).
    • angeschlossen an Onkyo Verstärker (Analog Stereo) TX-7820
    • 4 Hifi-Boxen (jeweils 3 Wege, Technics und CAT-No-Name)
    • Aufgabe: MP3 Wiedergabe
    2. Onboard (Asrock) AC97 Codec (5.1)
    • eingestellt auf 5.1 Sound
    • angeschlossen auf analoges 5.1 Subwoofer-Satelliten-Set aus dem ALDI
    • Aufgabe: 5.1 Sound für DVD's und DIVX-Filme liefern.
    Ich hoffe, dass ich das irgendwie eingestellt bekomme, wie es oben beschrieben ist. Problematisch könnte sein, dass die Treiberversorgung von Creative extrem beschissen ist. Die haben einfach keine passenden Windows-XP Treiber für diese Karte. Sie ist mit ihren 4 Jahren wohl schon zu alt. So einen schlechten Support hab ich bei einem Markengerät noch nicht erlebt. Deswegen muss ich die generischen Soundblaster Live Treiber nutzen, die Windows-MCE2005 zum Glück mitbringt. Die sind ganz OK, aber haben nicht alle Einstellmöglichkeiten. Insbesondere ist es mir auch noch nicht gelungen das sog. "Audio-HQ" zu installieren, das einiges an Einstellungen erlaubt.

    Als Codec benutzeich für DVD's Power-DVD 6.0. ICh hoffe, dass man da einstellen kann, welche Karte er benutzt. Kann man das beim neuesten Windows-Media-Player mittlerweile irgendwo einstellen ?

    Bin ja mit MCE2005 auf diesen Scheißplayer festgelegt.

    Hardware- bzw. IRQ-technisch scheint alles zu funzen.

    Hat irgendjemand bzgl. der Treiber für die SB-Platinum 5.1 einen Tip für mich? Oder sonst irgendwelche Anmerkungen?

  6. #5
    Benutzerbild von Baschtler

    Registriert seit
    03.12.2004
    Beiträge
    133
    So, ich hab jetzt auch mal im Netz gesucht wie ein Depp, aber nix gefunden. Ist es im MediaPlayer 10.0 echt nicht möglich eine spezielle Soundkarte als "Output Device" festzulegen ? Jeder andere gängige MP3-Player kann das doch auch.

    Echt zum Ko .....
    Ich fang hier gleich an durchzudrehen ... im ganzen I-Net nix zu finden ... das Problem muss doch schon mal jemand gehabt haben.

    Kann mir da jemand mit einem Link oder einem Tip aushelfen?

  7. #6
    Benutzerbild von Fuchks

    Registriert seit
    25.01.2004
    Beiträge
    4.789
    Ganz schön laggy, wa?

  8. #7
    Benutzerbild von AndreasMD

    Registriert seit
    28.10.2001
    Beiträge
    7.972
    Zitat Zitat von Baschtler
    Ist es im MediaPlayer 10.0 echt nicht möglich eine spezielle Soundkarte als "Output Device" festzulegen ? Jeder andere gängige MP3-Player kann das doch auch.
    Yepp,
    Ich glaub das geht

    geh mal im WMP10 in die Optionen und dann unter Geräte.
    Dann klicks du in der Geräteliste 'Lautsprecher' an und dann auf 'Eigenschaften'
    Somit siehst du ein Auswahlfeld, wo du dein gewünschtes Audiogerät aussuchen kannst.
    Und das klappt sogar, hab ich auch schon durch

  9. #8
    Benutzerbild von Baschtler

    Registriert seit
    03.12.2004
    Beiträge
    133
    Jo, super, ich glaub das funktioniert. Muss jetzt erst mal wieder ein Image zurückspielen, weil ich gerade die Konfiguration total versaut hatte (mit diversen unbrauchbaren Codecs).

    EDIT: So jetzt hab ich das mal ausgestestet und muss sagen, es überzeugt mich nicht. Momentan hab ich noch total die Brummschleife und mein Software-Setup ist suboptimal.

    Unter Software-Setup verstehe ich meine Audio-Einstellungen unter Windows MCE2005. Ich hatte den Onboard 5.1-Sound als primäre Soundkarte laufen, damit Power-DVD ihn auch verwendet (für Filme etc.). Die Soundblaster Platinum war nur als sekundäre Karte eingestellt und im Media-Player 10.0 als Soundkarte eingestellt.

    Leider hatte ich mit diesem Setup eine extreme Brummschleife, allerdings nur sobald ich bei MCE2005 in der MCE-Oberfläche war und auch nur dann, wenn die Lautstärke im Windows Mixer nicht auf Maximum stand. Sehr seltsam. Da muss ich wohl noch ein bissel baschteln. Hehe, am Besten gleich mal den Schutzstecker abisolieren. Ok, Ok, war nur ein Witz, ich weiß, dass das schnell übel ausgehen kann.

    Schade, dass Power-DVD selbst in der 6.0 Version immer noch keine Auswahl der Soundkarte erlaubt. Dann könnte ich nämlich die primäre Soundkarte andersrum einstellen.

    Weiß jemand wie man Power-DVD 6.0 dazu überreden kann eine andere Soundkarte als die Default-Karte zu verwenden ? Welche Software DVD-Player können das ?

  10. #9
    Benutzerbild von AndreasMD

    Registriert seit
    28.10.2001
    Beiträge
    7.972
    au, das sieht schwierig aus. Wie man PDVD das beibringen kann. Vielleicht über einen Reg-Eintrag. Aber welcher?

Ähnliche Themen

  1. digital und analog
    Von Ownnemesis im Forum Audioabteilung
    Antworten: 9
    Letzter Beitrag: 25.10.2009, 17:24
  2. Digital uns Analog TV
    Von andrej im Forum Grafikkarten & TV-Karten
    Antworten: 3
    Letzter Beitrag: 25.10.2004, 17:08
  3. digital und analog tv
    Von Thybald im Forum Hardware generell
    Antworten: 1
    Letzter Beitrag: 10.09.2004, 10:08
  4. DVB-C Analog und Digital?!
    Von MadMaik im Forum Grafikkarten & TV-Karten
    Antworten: 0
    Letzter Beitrag: 20.06.2004, 11:03
  5. digital + analog
    Von edgaruser im Forum Grafikkarten & TV-Karten
    Antworten: 2
    Letzter Beitrag: 05.04.2004, 12:20